Can't Start ScarabIDE

Home Forums Scarab IDE Can't Start ScarabIDE

This topic contains 0 replies, has 1 voice, and was last updated by  abeowitz2 4 years, 3 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #1448

    abeowitz2
    Participant

    I’m on Arch Linux, 64bit.

    ./Scarab_IDE

    /home/abe/ScarabIDE/lib
    java.lang.IllegalArgumentException: Argument cannot be null
    at org.eclipse.swt.SWT.error(Unknown Source)
    at org.eclipse.swt.SWT.error(Unknown Source)
    at org.eclipse.swt.SWT.error(Unknown Source)
    at org.eclipse.swt.widgets.Dialog.error(Unknown Source)
    at org.eclipse.swt.widgets.Dialog.checkParent(Unknown Source)
    at org.eclipse.swt.widgets.Dialog.<init>(Unknown Source)
    at org.eclipse.swt.widgets.MessageBox.<init>(Unknown Source)
    at com.embeddedmicro.mojo.MainWindow.showError(MainWindow.java:1180)
    at com.embeddedmicro.mojo.MainWindow.loadFonts(MainWindow.java:254)
    at com.embeddedmicro.mojo.MainWindow.createContents(MainWindow.java:301)
    at com.embeddedmicro.mojo.MainWindow.open(MainWindow.java:136)
    at com.embeddedmicro.mojo.MainWindow.main(MainWindow.java:83)

    java -version

    openjdk version “1.8.0_51”
    OpenJDK Runtime Environment (build 1.8.0_51-b16)

    BTW, Xilinx ISE appears to work.

    Do I need to add a command line argument/parameter?

    Thanks…

    • This topic was modified 4 years, 3 months ago by  abeowitz2.
Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.